https://my.defense.com/ connectivity issues
Incident Report for Defense.com
Resolved
The issues affecting connectivity to https://my.defense.com are now fully resolved.
Posted Jun 23, 2022 - 15:58 UTC
Investigating
Our Engineering team are currently investigating the cause of errors when attempting to connect to https://my.defense.com/.

As soon as further information or updates become available, they'll be added to this page.

Please accept our sincere apologies for any inconvenience this may be causing.
Posted Jun 23, 2022 - 15:34 UTC
This incident affected: My.Defense.com.