https://my.defense.com/ connectivity issues
Incident Report for Defense.com
Resolved
After monitoring the performance of the platform, we're pleased to confirm that the issue now appears to be fully resolved.
Posted Jun 21, 2022 - 10:18 UTC
Monitoring
Access to https://my.defense.com/ has now been restored - we'll continue to monitor this before considering the issue fully resolved.
Posted Jun 21, 2022 - 07:32 UTC
Investigating
Our Engineering team are currently investigating the cause of errors when attempting to connect to https://my.defense.com/.

As soon as further information or updates become available, they'll be added to this page.

Please accept our sincere apologies for any inconvenience this may be causing.
Posted Jun 21, 2022 - 06:49 UTC
This incident affected: My.Defense.com.